aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcel Metz <[email protected]>2017-03-04 23:22:45 +0100
committerMarcel Metz <[email protected]>2017-03-05 00:14:49 +0100
commitad640245d85502f673480a21d06f6259f507f279 (patch)
tree2e91273367ec192ac50c396c9b0e232d4bed6119 /CMakeLists.txt
parentdf87cf8002ace806879ef3646543d7f4037ba52e (diff)
Export cmake import targets for project build tree
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0f349b4..70709444 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1331,6 +1331,9 @@ IF(ALSOFT_INSTALL)
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
INCLUDES DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
)
+ EXPORT(TARGETS OpenAL
+ NAMESPACE OpenAL::
+ FILE OpenALConfig.cmake)
INSTALL(EXPORT OpenAL
DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/OpenAL
NAMESPACE OpenAL::