aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2018-11-15 21:42:17 -0800
committerChris Robinson <[email protected]>2018-11-15 21:42:17 -0800
commitcc113ce6aba8970cb9c111695c71400b2b8d39c3 (patch)
treeedda0c854de39fafa2612878f4025654e25d4de0 /CMakeLists.txt
parent9d43b548cc982d6ac90ccad82990f96622e74308 (diff)
Convert the OpenSL backend factory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66a2dbe5..6942fa46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1235,7 +1235,7 @@ IF(HAVE_SLES_OPENSLES_ANDROID_H)
OPTION(ALSOFT_BACKEND_OPENSL "Enable OpenSL backend" ON)
IF(ALSOFT_BACKEND_OPENSL)
SET(HAVE_OPENSL 1)
- SET(ALC_OBJS ${ALC_OBJS} Alc/backends/opensl.cpp)
+ SET(ALC_OBJS ${ALC_OBJS} Alc/backends/opensl.cpp Alc/backends/opensl.h)
SET(BACKENDS "${BACKENDS} OpenSL,")
SET(EXTRA_LIBS OpenSLES ${EXTRA_LIBS})
ENDIF()