aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2011-05-21 21:57:44 -0700
committerChris Robinson <[email protected]>2011-05-21 21:57:44 -0700
commitd07e94056d9522b70616e4e826156fccbbd6f278 (patch)
tree54ec3c184fdae8c7d13f7dbb05c69438bc7eddc4 /CMakeLists.txt
parent4d7aab1df42084a37cc7cda3b01b9fcc1f5ab360 (diff)
Use libuuid when it has MMDevApi's UIDs
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78961b09..0b3e93f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -338,6 +338,12 @@ IF(HAVE_LIBWINMM)
ENDIF()
+CHECK_LIBRARY_EXISTS(uuid CLSID_MMDeviceEnumerator "" HAVE_LIBUUID)
+IF(HAVE_LIBUUID)
+ SET(EXTRA_LIBS uuid ${EXTRA_LIBS})
+ENDIF()
+
+
SET(OPENAL_OBJS OpenAL32/alAuxEffectSlot.c
OpenAL32/alBuffer.c
OpenAL32/alDatabuffer.c