aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-18 09:31:32 -0700
committerChris Robinson <[email protected]>2019-09-18 09:31:32 -0700
commitda80a7c2b2e4a66856bec4d7b44c7a7df05a31a5 (patch)
tree6def50ec06d95dde868b32fa6c975870df45cccb /CMakeLists.txt
parentab87e56b22a49e04ca614d71e8a848b0658327af (diff)
Disable warnings 4268 and 4324 on MSVC
warning C4268: 'const' static/global data initialized with compiler generated default constructor fills the object with zeros warning C4324: structure was padded due to alignment specifier
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8da3d93c..3ef1ca6b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -199,7 +199,7 @@ IF(MSVC)
IF(HAVE_PERMISSIVE_SWITCH)
SET(C_FLAGS ${C_FLAGS} $<$<COMPILE_LANGUAGE:CXX>:/permissive->)
ENDIF()
- SET(C_FLAGS ${C_FLAGS} /W4 /w14640 /wd4065 /wd4200)
+ SET(C_FLAGS ${C_FLAGS} /W4 /w14640 /wd4065 /wd4200 /wd4268 /wd4324)
IF(NOT DXSDK_DIR)
STRING(REGEX REPLACE "\\\\" "/" DXSDK_DIR "$ENV{DXSDK_DIR}")