aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-11-18 03:24:49 -0800
committerChris Robinson <[email protected]>2008-11-18 03:24:49 -0800
commit0ecb34b8505f8bcb065b56dbc0ec489f977c10ae (patch)
tree948a77b7c8f1b434138cdf72aa67d34a08b10f12 /CMakeLists.txt
parent1f86c48d95a3131bdc7aa403e8e8c8a2a8a2d568 (diff)
Non-cross-compiled DLLs shouldn't have lib prefixed
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26e6f79c..44970e7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -344,6 +344,9 @@ ENDIF()
ADD_LIBRARY(${LIBNAME} ${LIBTYPE} ${OPENAL_OBJS} ${ALC_OBJS})
SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES VERSION ${LIB_VERSION}
SOVERSION ${LIB_MAJOR_VERSION})
+IF(WIN32)
+ SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES PREFIX "")
+ENDIF()
IF(XCOMPILEWIN32)
SET_TARGET_PROPERTIES(${LIBNAME} PROPERTIES PREFIX "" SUFFIX .dll)
IF(EXAMPLES)