aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2018-11-17 17:32:32 -0800
committerChris Robinson <[email protected]>2018-11-17 17:35:52 -0800
commit2d4ff77410d4fe647950c4e06dbe1c5536235796 (patch)
tree94a6ac1114d2c35222c752c400778192e9254d18 /CMakeLists.txt
parente5442db803b5ecac2bbbe45073e01de32431c0a5 (diff)
Remove ASSUME_ALIGNED
It's become a liability with C++ since it returns void* instead of the input pointer type, and it doesn't seem to help optimizations anyway (auto- vectorization still produces unaligned loads and stores).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cca21465..d4c48fcd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -445,19 +445,6 @@ ELSE()
SET(CMAKE_REQUIRED_FLAGS "${OLD_REQUIRED_FLAGS}")
ENDIF()
-CHECK_C_SOURCE_COMPILES("
-int main()
-{
- float *ptr;
- ptr = __builtin_assume_aligned(ptr, 16);
- return 0;
-}" HAVE___BUILTIN_ASSUME_ALIGNED)
-IF(HAVE___BUILTIN_ASSUME_ALIGNED)
- SET(ASSUME_ALIGNED_DECL "__builtin_assume_aligned(x, y)")
-ELSE()
- SET(ASSUME_ALIGNED_DECL "(x)")
-ENDIF()
-
SET(SSE_SWITCH "")
SET(SSE2_SWITCH "")
SET(SSE3_SWITCH "")