aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-02-11 11:44:35 -0800
committerChris Robinson <[email protected]>2019-02-11 11:44:35 -0800
commit2fc8461c14074c7f19d6c226e1beaf55aed441a0 (patch)
tree35c302185f85110cff026c9604dc4a514ca6fb51 /CMakeLists.txt
parentdac609b29ab11f6b2739250a3de91b125056e3a1 (diff)
Don't check for __int64
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 3 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5265cc66..2edaa377 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -673,17 +673,9 @@ CHECK_SYMBOL_EXISTS(getopt unistd.h HAVE_GETOPT)
# Check for a 64-bit type
CHECK_INCLUDE_FILE(stdint.h HAVE_STDINT_H)
IF(NOT HAVE_STDINT_H)
- IF(HAVE_WINDOWS_H)
- CHECK_C_SOURCE_COMPILES("#define _WIN32_WINNT 0x0502
- #include <windows.h>
- __int64 foo;
- int main() {return 0;}" HAVE___INT64)
- ENDIF()
- IF(NOT HAVE___INT64)
- IF(NOT SIZEOF_LONG MATCHES "8")
- IF(NOT SIZEOF_LONG_LONG MATCHES "8")
- MESSAGE(FATAL_ERROR "No 64-bit types found, please report!")
- ENDIF()
+ IF(NOT SIZEOF_LONG MATCHES "8")
+ IF(NOT SIZEOF_LONG_LONG MATCHES "8")
+ MESSAGE(FATAL_ERROR "No 64-bit types found, please report!")
ENDIF()
ENDIF()
ENDIF()