aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-14 18:27:57 -0700
committerChris Robinson <[email protected]>2019-09-14 18:35:23 -0700
commit807d3b64cac2793ce678acb3fc4d4191b2252875 (patch)
treeb766e0838c75fcf069015078259c5bfbd56bce63 /CMakeLists.txt
parent2cc0600476fc4ed13a64eeb59c02c213bd3b6dd4 (diff)
Enable and fix more warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ec17ce5..44d829d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -220,11 +220,8 @@ IF(MSVC)
ENDFOREACH(flag_var)
ENDIF()
ELSE()
- SET(C_FLAGS ${C_FLAGS} -Winline -Wall $<$<COMPILE_LANGUAGE:CXX>:-Wold-style-cast> -Wconversion)
- CHECK_C_COMPILER_FLAG(-Wextra HAVE_W_EXTRA)
- IF(HAVE_W_EXTRA)
- SET(C_FLAGS ${C_FLAGS} -Wextra)
- ENDIF()
+ SET(C_FLAGS ${C_FLAGS} -Winline -Wall -Wextra -Wshadow -Wconversion -Wcast-align
+ $<$<COMPILE_LANGUAGE:CXX>:-Wold-style-cast -Wnon-virtual-dtor -Woverloaded-virtual>)
IF(ALSOFT_WERROR)
SET(C_FLAGS ${C_FLAGS} -Werror)