aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-09-16 15:10:36 -0700
committerChris Robinson <[email protected]>2019-09-16 15:10:36 -0700
commit899a414591559633f2641a74325dffc5e54562c7 (patch)
tree5cd3b23181266634ff89fd3bc3ea68862bc0762c /CMakeLists.txt
parent6d93b2ba81958eb277da4361924e89bc7048da41 (diff)
Remove the last uses of the system's str[n]casecmp
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32cb017e..c1bc09cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -473,26 +473,6 @@ CHECK_SYMBOL_EXISTS(_aligned_malloc malloc.h HAVE__ALIGNED_MALLOC)
CHECK_SYMBOL_EXISTS(proc_pidpath libproc.h HAVE_PROC_PIDPATH)
CHECK_FUNCTION_EXISTS(stat HAVE_STAT)
-CHECK_FUNCTION_EXISTS(strcasecmp HAVE_STRCASECMP)
-IF(NOT HAVE_STRCASECMP)
- CHECK_FUNCTION_EXISTS(_stricmp HAVE__STRICMP)
- IF(NOT HAVE__STRICMP)
- MESSAGE(FATAL_ERROR "No case-insensitive compare function found, please report!")
- ENDIF()
-
- SET(CPP_DEFS ${CPP_DEFS} strcasecmp=_stricmp)
-ENDIF()
-
-CHECK_FUNCTION_EXISTS(strncasecmp HAVE_STRNCASECMP)
-IF(NOT HAVE_STRNCASECMP)
- CHECK_FUNCTION_EXISTS(_strnicmp HAVE__STRNICMP)
- IF(NOT HAVE__STRNICMP)
- MESSAGE(FATAL_ERROR "No case-insensitive size-limitted compare function found, please report!")
- ENDIF()
-
- SET(CPP_DEFS ${CPP_DEFS} strncasecmp=_strnicmp)
-ENDIF()
-
IF(NOT WIN32)
# We need pthreads outside of Windows, for semaphores. It's also used to