aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2019-07-28 15:37:12 -0700
committerChris Robinson <[email protected]>2019-07-28 15:37:12 -0700
commitc8bbd75bf9a6f0170ec95b130b3eb17cd8cdd5ad (patch)
tree96d2734c219b897b711896ca96b4d22818079362 /CMakeLists.txt
parent12e179d53952f2820250049ee4f87495944e714e (diff)
Remove a couple more cmake checks
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d274626..53361f0b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,9 +243,6 @@ ELSE()
SET(C_FLAGS ${C_FLAGS} -fno-math-errno)
ENDIF()
- CHECK_C_SOURCE_COMPILES("int foo() __attribute__((destructor));
- int main() {return 0;}" HAVE_GCC_DESTRUCTOR)
-
option(ALSOFT_STATIC_LIBGCC "Force -static-libgcc for static GCC runtimes" OFF)
if(ALSOFT_STATIC_LIBGCC)
set(OLD_REQUIRED_LIBRARIES ${CMAKE_REQUIRED_LIBRARIES})
@@ -474,7 +471,6 @@ IF(HAVE_INTRIN_H)
}" HAVE_BITSCANFORWARD_INTRINSIC)
ENDIF()
-CHECK_SYMBOL_EXISTS(sysconf unistd.h HAVE_SYSCONF)
CHECK_SYMBOL_EXISTS(posix_memalign stdlib.h HAVE_POSIX_MEMALIGN)
CHECK_SYMBOL_EXISTS(_aligned_malloc malloc.h HAVE__ALIGNED_MALLOC)
CHECK_SYMBOL_EXISTS(proc_pidpath libproc.h HAVE_PROC_PIDPATH)