aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2010-11-28 14:27:07 -0800
committerChris Robinson <[email protected]>2010-11-28 14:27:07 -0800
commit490d1c6a8ec45bb6cfd80f92155ae6ae93098785 (patch)
treeaeab3a5d2b3a7e14165437c2e0921797d6648575 /CMakeLists.txt
parent0e748d98d5db22d259e0803f5318fb61bc7e9c2e (diff)
Prefer GCC's constructor, even in Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c629c425..c9de3285 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -119,11 +119,11 @@ ELSE()
"Flags used by the compiler during debug builds."
FORCE)
+ CHECK_C_SOURCE_COMPILES("int foo() __attribute__((destructor));
+ int main() {return 0;}" HAVE_GCC_DESTRUCTOR)
+
# Set visibility options if available
IF(NOT WIN32)
- CHECK_C_SOURCE_COMPILES("int foo() __attribute__((destructor));
- int main() {return 0;}" HAVE_GCC_DESTRUCTOR)
-
CHECK_C_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_SWITCH)
IF(HAVE_VISIBILITY_SWITCH)
CHECK_C_SOURCE_COMPILES("int foo() __attribute__((visibility(\"default\")));