aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-02-08 20:46:34 -0800
committerChris Robinson <[email protected]>2008-02-08 20:46:34 -0800
commit4c38ed272d2b9626cf65abb3dcfb6ad393dc0ea0 (patch)
tree6a54ce0676cef86517709d8ef2f03f0cdcc722bd /CMakeLists.txt
parentacbb4f8e6cd95fa31b67e6af77aa61f88cfc3e11 (diff)
Enumerate DirectSound devices
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0bcb3b44..46c34e3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,6 +266,14 @@ IF(HAVE_WINDOWS_H)
IF(HAVE_LIBDXGUID)
SET(EXTRA_LIBS dxguid ${EXTRA_LIBS})
ENDIF()
+
+ SET(CMAKE_REQUIRED_LIBRARIES dsound)
+ CHECK_C_SOURCE_COMPILES("int main() {return 0;}" HAVE_LIBDSOUND)
+ SET(CMAKE_REQUIRED_LIBRARIES "")
+# CHECK_LIBRARY_EXISTS(dsound DirectSoundCreate "" HAVE_LIBDSOUND)
+ IF(HAVE_LIBDSOUND)
+ SET(EXTRA_LIBS dsound ${EXTRA_LIBS})
+ ENDIF()
ENDIF()
ENDIF()
IF(WINMM)