aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2008-07-23 00:51:55 -0700
committerChris Robinson <[email protected]>2008-07-23 00:51:55 -0700
commit5a9e24dea17ae2105402176cbfd3e86be4f1b35b (patch)
tree345ecb49157e48aa0b68a6671a3405b1b8bcdcfc /CMakeLists.txt
parentdc8132e965d93200e6b2ad0ecedfc97373896db8 (diff)
Add a warning when building on Windows with the DSound backend disabled
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7c5c33c..8942a0c8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -354,3 +354,9 @@ MESSAGE(STATUS "")
MESSAGE(STATUS "Building OpenAL with support for the following backends:")
MESSAGE(STATUS " ${BACKENDS}")
MESSAGE(STATUS "")
+
+IF(WIN32 AND NOT HAVE_DSOUND)
+ MESSAGE(STATUS "WARNING: Building the Windows version without DirectSound output")
+ MESSAGE(STATUS " This is probably NOT what you want!")
+ MESSAGE(STATUS "")
+ENDIF()