aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2015-10-03 20:41:18 -0700
committerChris Robinson <[email protected]>2015-10-03 20:41:18 -0700
commit70fbc2b1ff254295338c6d42b41d9fdb43b02d8f (patch)
tree71b1e437aca72282b170d584f270c429a84b3149 /CMakeLists.txt
parentaa10068ca20c2241c8d80627a5be3aeb39efcea2 (diff)
Add a function to get a list of data files
The method takes a marked-up filename (e.g. may include %r for a sample rate, %% for %, etc), and returns a vector of strings of found filenames that match. It will search the CWD, the local, and global data directories, in that order.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 39fdd44e..ea2d5150 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -337,7 +337,7 @@ CHECK_C_SOURCE_COMPILES("int foo(const char *str, ...) __attribute__((format(pri
CHECK_INCLUDE_FILE(stdbool.h HAVE_STDBOOL_H)
CHECK_INCLUDE_FILE(stdalign.h HAVE_STDALIGN_H)
CHECK_INCLUDE_FILE(malloc.h HAVE_MALLOC_H)
-CHECK_INCLUDE_FILE(ftw.h HAVE_FTW_H)
+CHECK_INCLUDE_FILE(dirent.h HAVE_DIRENT_H)
CHECK_INCLUDE_FILE(io.h HAVE_IO_H)
CHECK_INCLUDE_FILE(strings.h HAVE_STRINGS_H)
CHECK_INCLUDE_FILE(cpuid.h HAVE_CPUID_H)