aboutsummaryrefslogtreecommitdiffstats
path: root/utils/alsoft-config/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2013-06-24 05:02:45 -0700
committerChris Robinson <[email protected]>2013-06-24 05:02:45 -0700
commitf48c0c9e0ac09bca5a15966c3862119dc19019f3 (patch)
tree5f73c27131d06c8294a29c2514e5b8b9b238092e /utils/alsoft-config/CMakeLists.txt
parentb3f54124bd151a7ed9e7d2832cb88c72db31a8e8 (diff)
Make sure QtCore and QtGui were found and link with the appropriate libs
Diffstat (limited to 'utils/alsoft-config/CMakeLists.txt')
-rw-r--r--utils/alsoft-config/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/utils/alsoft-config/CMakeLists.txt b/utils/alsoft-config/CMakeLists.txt
index 419be91c..b5ac6b72 100644
--- a/utils/alsoft-config/CMakeLists.txt
+++ b/utils/alsoft-config/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories("${alsoft-config_BINARY_DIR}")
# Need Qt 4.8.0 or newer for the iconset theme attribute to work
find_package(Qt4 COMPONENTS QtCore QtGui)
-if(QT4_FOUND AND ("${QT_VERSION_MAJOR}" GREATER "4" OR ("${QT_VERSION_MAJOR}" EQUAL "4" AND "${QT_VERSION_MINOR}" GREATER "7")))
+if(QT_QTCORE_FOUND AND QT_QTGUI_FOUND AND ("${QT_VERSION_MAJOR}" GREATER "4" OR ("${QT_VERSION_MAJOR}" EQUAL "4" AND "${QT_VERSION_MINOR}" GREATER "7")))
include(${QT_USE_FILE})
include_directories(${QT_QTCORE_INCLUDE_DIR} ${QT_QTGUI_INCLUDE_DIR})
@@ -20,7 +20,7 @@ if(QT4_FOUND AND ("${QT_VERSION_MAJOR}" GREATER "4" OR ("${QT_VERSION_MAJOR}" EQ
QT4_WRAP_CPP(MOCS ${alsoft-config_MOCS})
add_executable(../../alsoft-config ${alsoft-config_SRCS} ${UIS} ${RSCS} ${TRS} ${MOCS})
- target_link_libraries(../../alsoft-config ${QT_QTCORE_LIBRARY} ${QT_QTGUI_LIBRARY})
+ target_link_libraries(../../alsoft-config ${QT_LIBRARIES})
INSTALL(TARGETS ../../alsoft-config
RUNTIME DESTINATION bin