aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86fc4fd1..32f717a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,11 @@ IF(NOT "${HAVE_WINDOWS_H}")
MESSAGE(FATAL_ERROR "No timing function found!")
ENDIF()
+ CHECK_FUNCTION_EXISTS(usleep HAVE_USLEEP)
+ IF(NOT "${HAVE_USLEEP}")
+ MESSAGE(FATAL_ERROR "No sleep function found!")
+ ENDIF()
+
# We need pthreads outside of Windows
CHECK_INCLUDE_FILE(pthread.h HAVE_PTHREAD_H)
IF(NOT "${HAVE_PTHREAD_H}")