aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 10 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d1690a8..c712a16a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1681,24 +1681,24 @@ if(ALSOFT_EXAMPLES)
set(FFVER_OK FALSE)
if(FFMPEG_FOUND)
set(FFVER_OK TRUE)
- if(AVFORMAT_VERSION VERSION_LESS "57.56.101")
- message(STATUS "libavformat is too old! (${AVFORMAT_VERSION}, wanted 57.56.101)")
+ if(AVFORMAT_VERSION VERSION_LESS "59.27.100")
+ message(STATUS "libavformat is too old! (${AVFORMAT_VERSION}, wanted 59.27.100)")
set(FFVER_OK FALSE)
endif()
- if(AVCODEC_VERSION VERSION_LESS "57.64.101")
- message(STATUS "libavcodec is too old! (${AVCODEC_VERSION}, wanted 57.64.101)")
+ if(AVCODEC_VERSION VERSION_LESS "59.37.100")
+ message(STATUS "libavcodec is too old! (${AVCODEC_VERSION}, wanted 59.37.100)")
set(FFVER_OK FALSE)
endif()
- if(AVUTIL_VERSION VERSION_LESS "55.34.101")
- message(STATUS "libavutil is too old! (${AVUTIL_VERSION}, wanted 55.34.101)")
+ if(AVUTIL_VERSION VERSION_LESS "57.28.100")
+ message(STATUS "libavutil is too old! (${AVUTIL_VERSION}, wanted 57.28.100)")
set(FFVER_OK FALSE)
endif()
- if(SWSCALE_VERSION VERSION_LESS "4.2.100")
- message(STATUS "libswscale is too old! (${SWSCALE_VERSION}, wanted 4.2.100)")
+ if(SWSCALE_VERSION VERSION_LESS "6.7.100")
+ message(STATUS "libswscale is too old! (${SWSCALE_VERSION}, wanted 6.7.100)")
set(FFVER_OK FALSE)
endif()
- if(SWRESAMPLE_VERSION VERSION_LESS "2.3.100")
- message(STATUS "libswresample is too old! (${SWRESAMPLE_VERSION}, wanted 2.3.100)")
+ if(SWRESAMPLE_VERSION VERSION_LESS "4.7.100")
+ message(STATUS "libswresample is too old! (${SWRESAMPLE_VERSION}, wanted 4.7.100)")
set(FFVER_OK FALSE)
endif()
endif()