aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 78961b09..0b3e93f3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -338,6 +338,12 @@ IF(HAVE_LIBWINMM)
ENDIF()
+CHECK_LIBRARY_EXISTS(uuid CLSID_MMDeviceEnumerator "" HAVE_LIBUUID)
+IF(HAVE_LIBUUID)
+ SET(EXTRA_LIBS uuid ${EXTRA_LIBS})
+ENDIF()
+
+
SET(OPENAL_OBJS OpenAL32/alAuxEffectSlot.c
OpenAL32/alBuffer.c
OpenAL32/alDatabuffer.c