aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4efd396c..13f8e0a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -206,7 +206,11 @@ ENDIF()
# Set visibility/export options if available
IF(WIN32)
SET(EXPORT_DECL "__declspec(dllexport)")
- SET(ALIGN_DECL "__declspec(align(x))")
+ IF(NOT MINGW)
+ SET(ALIGN_DECL "__declspec(align(x))")
+ ELSE()
+ SET(ALIGN_DECL "__declspec(aligned(x))")
+ ENDIF()
OPTION(WINE "Enable use of Wine headers when compiling" OFF)
IF(WINE)