aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1140b053..8fbf775b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,6 +118,18 @@ IF(NOT HAVE_RESTRICT)
ENDIF()
ENDIF()
+CHECK_C_SOURCE_COMPILES("inline void foo(void) { }
+ int main() {return 0;}" HAVE_INLINE)
+IF(NOT HAVE_INLINE)
+ CHECK_C_SOURCE_COMPILES("__inline void foo(void) { }
+ int main() {return 0;}" HAVE___INLINE)
+ IF(NOT HAVE___INLINE)
+ MESSAGE(FATAL_ERROR "No inline keyword found, please report!")
+ ENDIF()
+
+ ADD_DEFINITIONS(-Dinline=__inline)
+ENDIF()
+
# Add definitions, compiler switches, etc.
INCLUDE_DIRECTORIES(OpenAL32/Include include "${OpenAL_BINARY_DIR}")