aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15311bc2..b7e459fd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -359,7 +359,6 @@ int main()
ENDIF()
# Set visibility/export options if available
-SET(HIDDEN_DECL "")
IF(WIN32)
SET(EXPORT_DECL "__declspec(dllexport)")
IF(NOT MINGW)
@@ -388,7 +387,6 @@ ELSE()
CHECK_C_COMPILER_FLAG(-fvisibility=hidden HAVE_VISIBILITY_HIDDEN_SWITCH)
IF(HAVE_VISIBILITY_HIDDEN_SWITCH)
SET(EXTRA_CFLAGS "${EXTRA_CFLAGS} -fvisibility=hidden")
- SET(HIDDEN_DECL "__attribute__((visibility(\"hidden\")))")
ENDIF()
ENDIF()