aboutsummaryrefslogtreecommitdiffstats
path: root/Alc/backends/oss.cpp
Commit message (Expand)AuthorAgeFilesLines
* Rename Alc to alcChris Robinson2019-07-281-751/+0
* Rename alMain.h to alcmain.hChris Robinson2019-07-281-1/+1
* Clean up includes a bitChris Robinson2019-07-281-16/+21
* Use an optional for ConfigValueStrChris Robinson2019-06-301-14/+11
* Don't log the function or prefixChris Robinson2019-06-041-2/+0
* Specify the buffer size as itself instead of the period countChris Robinson2019-04-261-5/+4
* Remove the backend factory deinit methodChris Robinson2019-04-141-6/+0
* Rename DevProbe enum namesChris Robinson2019-03-191-2/+2
* Use c++ headersFilip Gawin2019-01-091-5/+5
* Use an atomic bool on things that only take true or falseChris Robinson2018-12-301-6/+6
* Rename BackendLock to StateLockChris Robinson2018-12-301-4/+0
* Add missing includes for mem_fnChris Robinson2018-12-291-0/+1
* Return a unique_ptr for the backendChris Robinson2018-12-291-3/+3
* Make the backend type an enum classChris Robinson2018-12-291-5/+5
* Convert the backends to use proper inheritenceChris Robinson2018-12-281-168/+119
* Make more methods into member functionsChris Robinson2018-12-271-52/+52
* Rename some more struct members for consistencyChris Robinson2018-12-271-36/+36
* Get rid of the unnecessary STATIC_(UP)CAST macrosChris Robinson2018-12-271-9/+7
* Use a proper constructor/destructor for the ALCbackend baseChris Robinson2018-12-271-6/+6
* Return unique_ptrs instead of raw pointersChris Robinson2018-12-271-2/+1
* Clean up the ring buffer struct and use member functionsChris Robinson2018-12-261-5/+8
* Remove extraneous typedef, struct, and enum keywordsChris Robinson2018-12-241-3/+3
* Avoid using select()Chris Robinson2018-12-241-39/+25
* Use a normal delete instead of ll_ringbuffer_freeChris Robinson2018-12-221-8/+7
* Use inline methods for the device format sizesChris Robinson2018-12-191-11/+9
* Avoid using ATOMIC_LOAD on ALCdevice::ConnectedChris Robinson2018-11-261-1/+1
* Rename some struct membersChris Robinson2018-11-261-29/+29
* Replace remaining uses of std::vector with al::vectorChris Robinson2018-11-241-7/+7
* Return the ringbuffer data pointers as a pairChris Robinson2018-11-191-4/+3
* Use a std::string for the device nameChris Robinson2018-11-181-6/+2
* Avoid more cases of an enum variable and type name clashChris Robinson2018-11-181-7/+7
* Don't pass the current thread to althrd_setnameChris Robinson2018-11-171-2/+2
* Convert the OSS backend factoryChris Robinson2018-11-151-77/+54
* Remove checks for functions that always existChris Robinson2018-11-151-10/+0
* Use a regular char* for the device's nameChris Robinson2018-11-151-2/+4
* Use std::string instead of al_string for enumeratingChris Robinson2018-11-151-4/+4
* Use C++ more in the OSS backendChris Robinson2018-11-141-56/+49
* Use a C++ vector for enumerated OSS devicesChris Robinson2018-11-141-155/+146
* Use an anonymous namespace in the OSS backendChris Robinson2018-11-131-8/+12
* Convert the OSS backend to C++Chris Robinson2018-11-121-0/+875