Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rename Alc to alc | Chris Robinson | 2019-07-28 | 1 | -302/+0 |
| | |||||
* | Rename alMain.h to alcmain.h | Chris Robinson | 2019-07-28 | 1 | -1/+1 |
| | | | | And move it and alu.h to Alc/. | ||||
* | Use an optional for ConfigValueStr | Chris Robinson | 2019-06-30 | 1 | -5/+6 |
| | |||||
* | Don't log the function or prefix | Chris Robinson | 2019-06-04 | 1 | -1/+0 |
| | | | | | | It's ultimately unnecessary since the message is an indicator about where it was logged from. The message itself is generally more important than where it was from, too. | ||||
* | Specify the buffer size as itself instead of the period count | Chris Robinson | 2019-04-26 | 1 | -2/+3 |
| | | | | | | | Certain backends don't need a buffer size to be a strict multiple of the period count, which allows a little more flexibility. The period/update size simply acts as the minimum request, which helps control CPU load by determining how often parameter and other pre-mixing updates are processed. | ||||
* | Rename DevProbe enum names | Chris Robinson | 2019-03-19 | 1 | -2/+2 |
| | |||||
* | Add missing includes for mem_fn | Chris Robinson | 2018-12-29 | 1 | -0/+1 |
| | |||||
* | Return a unique_ptr for the backend | Chris Robinson | 2018-12-29 | 1 | -2/+2 |
| | |||||
* | Make the backend type an enum class | Chris Robinson | 2018-12-29 | 1 | -4/+4 |
| | |||||
* | Convert the backends to use proper inheritence | Chris Robinson | 2018-12-28 | 1 | -77/+47 |
| | |||||
* | Turn even more methods into member functions | Chris Robinson | 2018-12-28 | 1 | -64/+63 |
| | |||||
* | Use vectors instead of malloc'd buffers | Chris Robinson | 2018-12-27 | 1 | -15/+13 |
| | |||||
* | Finish renaming backend struct fields | Chris Robinson | 2018-12-27 | 1 | -20/+20 |
| | |||||
* | Get rid of the unnecessary STATIC_(UP)CAST macros | Chris Robinson | 2018-12-27 | 1 | -5/+4 |
| | |||||
* | Use a proper constructor/destructor for the ALCbackend base | Chris Robinson | 2018-12-27 | 1 | -3/+3 |
| | |||||
* | Remove extraneous typedef, struct, and enum keywords | Chris Robinson | 2018-12-24 | 1 | -1/+1 |
| | |||||
* | Avoid using select() | Chris Robinson | 2018-12-24 | 1 | -22/+15 |
| | |||||
* | Use inline methods for the device format sizes | Chris Robinson | 2018-12-19 | 1 | -8/+7 |
| | |||||
* | Remove the last remaining uses of althrd_t | Chris Robinson | 2018-11-26 | 1 | -12/+18 |
| | |||||
* | Avoid using ATOMIC_LOAD on ALCdevice::Connected | Chris Robinson | 2018-11-26 | 1 | -1/+1 |
| | |||||
* | Rename some struct members | Chris Robinson | 2018-11-26 | 1 | -5/+5 |
| | |||||
* | Avoid using the ATOMIC() macro | Chris Robinson | 2018-11-26 | 1 | -1/+1 |
| | |||||
* | Avoid using ATOMIC_INIT | Chris Robinson | 2018-11-26 | 1 | -8/+4 |
| | |||||
* | Remove the atomic exchange macros | Chris Robinson | 2018-11-19 | 1 | -1/+1 |
| | |||||
* | Use a std::string for the device name | Chris Robinson | 2018-11-18 | 1 | -2/+1 |
| | |||||
* | Avoid more cases of an enum variable and type name clash | Chris Robinson | 2018-11-18 | 1 | -4/+4 |
| | |||||
* | Don't pass the current thread to althrd_setname | Chris Robinson | 2018-11-17 | 1 | -1/+1 |
| | |||||
* | Convert the Solaris backend factory | Chris Robinson | 2018-11-15 | 1 | -34/+11 |
| | |||||
* | Use a regular char* for the device's name | Chris Robinson | 2018-11-15 | 1 | -1/+2 |
| | |||||
* | Use std::string instead of al_string for enumerating | Chris Robinson | 2018-11-15 | 1 | -3/+3 |
| | |||||
* | Convert the Solaris backend to C++ | Chris Robinson | 2018-11-12 | 1 | -0/+363 |