aboutsummaryrefslogtreecommitdiffstats
path: root/Alc/backends/wasapi.cpp
Commit message (Collapse)AuthorAgeFilesLines
* Rename Alc to alcChris Robinson2019-07-281-1763/+0
|
* Rename alMain.h to alcmain.hChris Robinson2019-07-281-1/+1
| | | | And move it and alu.h to Alc/.
* Clean up includes a bitChris Robinson2019-07-281-0/+4
| | | | | | | Trying out the IWYU tool to only include what's necessary in a given file. Seems to work decently (it'll miss some headers, suggest unnecessary ones, and make nonsense suggestions for some things, but overall gives a good starting point), and helps clean out some headers.
* Properly set extra fields in MakeExtensibleChris Robinson2019-06-271-1/+5
|
* Trace the requested and required formats for WASAPIChris Robinson2019-06-271-38/+94
|
* Make sure the bitfield indices are constantsChris Robinson2019-06-091-2/+2
|
* Use a bitfield for the device flagsChris Robinson2019-06-081-2/+2
|
* Don't log the function or prefixChris Robinson2019-06-041-4/+0
| | | | | | It's ultimately unnecessary since the message is an indicator about where it was logged from. The message itself is generally more important than where it was from, too.
* Don't change the format tag in MakeExtensibleChris Robinson2019-05-211-8/+10
|
* Fix a couple type truncation warnings with MSVCChris Robinson2019-05-121-1/+1
|
* Don't round WASAPI updates to the update sizeChris Robinson2019-04-271-1/+0
|
* Scale the update size with sample rate changesChris Robinson2019-04-261-9/+6
|
* Specify the buffer size as itself instead of the period countChris Robinson2019-04-261-23/+23
| | | | | | | Certain backends don't need a buffer size to be a strict multiple of the period count, which allows a little more flexibility. The period/update size simply acts as the minimum request, which helps control CPU load by determining how often parameter and other pre-mixing updates are processed.
* Remove the backend factory deinit methodChris Robinson2019-04-141-9/+0
| | | | | | It was never actually called anywhere, and there's no safe place where it can be called. It's probably better to let the individual backends worry about cleaning themselves up anyway.
* Use a custom message queue for the WASAPI backendChris Robinson2019-04-141-263/+160
|
* Add some enum casts for the WASAPI backendChris Robinson2019-03-191-5/+5
|
* Rename DevProbe enum namesChris Robinson2019-03-191-6/+6
|
* Avoid using internal AL[u]int64 typesChris Robinson2019-02-111-1/+1
|
* Handle a missing default WASAPI device IDChris Robinson2019-01-181-3/+3
|
* Use an atomic bool on things that only take true or falseChris Robinson2018-12-301-6/+6
|
* Rename BackendLock to StateLockChris Robinson2018-12-301-10/+0
|
* Use member functions for the sample and channel convertersChris Robinson2018-12-291-5/+5
|
* Add missing includes for mem_fnChris Robinson2018-12-291-0/+1
|
* Return a unique_ptr for the backendChris Robinson2018-12-291-3/+3
|
* Make the backend type an enum classChris Robinson2018-12-291-5/+5
|
* Convert the backends to use proper inheritenceChris Robinson2018-12-281-159/+103
|
* Use static_cast instead of reinterpret_cast where possibleChris Robinson2018-12-281-16/+16
|
* Finish turning ancillary backend methods into member functionsChris Robinson2018-12-281-157/+156
|
* Get rid of the unnecessary STATIC_(UP)CAST macrosChris Robinson2018-12-271-90/+77
|
* Use a proper constructor/destructor for the ALCbackend baseChris Robinson2018-12-271-6/+6
|
* Return unique_ptrs instead of raw pointersChris Robinson2018-12-271-20/+13
| | | | For the ring buffer, channel converter, and sample converter.
* Clean up the ring buffer struct and use member functionsChris Robinson2018-12-261-5/+8
|
* Remove extraneous typedef, struct, and enum keywordsChris Robinson2018-12-241-2/+2
|
* Use a normal delete instead of ll_ringbuffer_freeChris Robinson2018-12-221-12/+6
| | | | And use RingBufferPtr in more places
* Use inline methods for the device format sizesChris Robinson2018-12-191-8/+4
|
* Avoid several uses of memsetChris Robinson2018-12-081-1/+1
|
* Pass the desired resampler to CreateSampleConverterChris Robinson2018-11-281-1/+1
|
* Avoid the update size going to 0 with a relatively large device periodChris Robinson2018-11-281-1/+1
|
* Replace remaining uses of std::vector with al::vectorChris Robinson2018-11-241-6/+6
| | | | Which uses a custom allocator that uses our allocation functions.
* Use proper time types for the device clock time and latencyChris Robinson2018-11-221-2/+2
|
* Return the ringbuffer data pointers as a pairChris Robinson2018-11-191-9/+10
|
* Use a std::string for the device nameChris Robinson2018-11-181-16/+6
|
* Avoid more cases of an enum variable and type name clashChris Robinson2018-11-181-3/+3
|
* Don't pass the current thread to althrd_setnameChris Robinson2018-11-171-2/+2
|
* Convert the WASAPI backend factoryChris Robinson2018-11-151-79/+55
|
* Remove the unused al_string APIChris Robinson2018-11-151-1/+0
|
* Use a regular char* for the device's nameChris Robinson2018-11-151-10/+12
|
* Search the right list for WASAPI name duplicatesChris Robinson2018-11-151-1/+1
|
* Use std::string instead of al_string for enumeratingChris Robinson2018-11-151-5/+3
|
* Avoid calling through the vtable in the backendsChris Robinson2018-11-131-10/+10
|