Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rename Alc to alc | Chris Robinson | 2019-07-28 | 1 | -15/+0 |
| | |||||
* | Remove the DEF_ALIGN macro | Chris Robinson | 2019-06-06 | 1 | -1/+1 |
| | |||||
* | Remove the unused vector macros | Chris Robinson | 2018-11-18 | 1 | -82/+0 |
| | |||||
* | Move the alignment-aware allocator and vector to headers | Chris Robinson | 2018-11-18 | 1 | -50/+21 |
| | |||||
* | Add a more C++-friendly VECTOR_RESIZE | Chris Robinson | 2018-10-29 | 1 | -0/+32 |
| | |||||
* | Avoid dereferencing a NULL pointer | Chris Robinson | 2017-12-31 | 1 | -1/+2 |
| | | | | | | Even though it's taking the address of a member, it's still technically a derefernce and thus undefined behavior. sizeof doesn't "execute" the expression, so derefering in it instead is fine. | ||||
* | Remove a couple unused macros | Chris Robinson | 2017-04-01 | 1 | -18/+0 |
| | |||||
* | Don't rely on sizeof being the offset to a struct's unsized array | Chris Robinson | 2017-04-01 | 1 | -2/+3 |
| | |||||
* | Remove an unneeded typedef | Chris Robinson | 2016-08-21 | 1 | -5/+0 |
| | |||||
* | Combine VECTOR_RESIZE and VECTOR_RESERVE | Chris Robinson | 2016-07-26 | 1 | -8/+31 |
| | |||||
* | Remove unnecessary VECTOR_INSERT | Chris Robinson | 2016-05-30 | 1 | -15/+0 |
| | |||||
* | Avoid using realloc in a number of places | Chris Robinson | 2016-05-21 | 1 | -1/+3 |
| | |||||
* | Shorten VECTOR_ITER_ macros to VECTOR_ | Chris Robinson | 2016-04-15 | 1 | -10/+10 |
| | |||||
* | Enumerate and list HRTFs per-device | Chris Robinson | 2015-10-06 | 1 | -0/+18 |
| | |||||
* | Use size_t for the vector size and capacity | Chris Robinson | 2014-09-30 | 1 | -8/+8 |
| | |||||
* | Simplify some vector size range checks | Chris Robinson | 2014-08-10 | 1 | -5/+5 |
| | |||||
* | Give NULL for null-vector iterators | Chris Robinson | 2014-08-10 | 1 | -2/+2 |
| | |||||
* | Pass pointer-to-vector types as char* instead of void* | Chris Robinson | 2014-08-10 | 1 | -9/+8 |
| | | | | | C aliasing rules only allow char* to alias an otherwise-incompatible type, rather than void*. | ||||
* | Access the result macro parameter only once | Chris Robinson | 2014-07-06 | 1 | -3/+4 |
| | |||||
* | Allow ALsoundfont_deleteSoundfont to handle multiple buffers | Chris Robinson | 2014-07-06 | 1 | -0/+10 |
| | |||||
* | Don't require pre-declaring vector types | Chris Robinson | 2014-07-06 | 1 | -6/+14 |
| | |||||
* | Remove an unnecessary cast | Chris Robinson | 2014-07-01 | 1 | -2/+2 |
| | |||||
* | Revert e9aee578a797c694655538cd0a00ad6c0bf6d5dc | Chris Robinson | 2014-05-02 | 1 | -2/+2 |
| | | | | | The vector iterator needs to be the start of the Data array even if the vector itself is NULL, or else insertion can have a negative insert position. | ||||
* | Add a helper VECTOR_FOR_EACH macro | Chris Robinson | 2014-04-30 | 1 | -0/+7 |
| | |||||
* | Avoid dereferencing a NULL pointer | Chris Robinson | 2014-04-21 | 1 | -2/+2 |
| | |||||
* | Ensure VECTOR_ITER_BEGIN gives a pointer-to-type instead of an array-of-type | Chris Robinson | 2014-04-14 | 1 | -1/+1 |
| | |||||
* | Add a GCC-specific VECTOR_INSERT | Chris Robinson | 2014-04-13 | 1 | -0/+12 |
| | | | | | | This version is capable of doing a compile-time type checks, to ensure the objects being inserted are compatible with the vector data type. It should otherwise be functionally identical. | ||||
* | Pass in the vector insertion point as a pointer | Chris Robinson | 2014-04-13 | 1 | -2/+2 |
| | |||||
* | Avoid referencing the start iterator twice for vector insertion | Chris Robinson | 2014-04-13 | 1 | -2/+2 |
| | |||||
* | Add a VECTOR_INSERT method to insert a range of elements at once | Chris Robinson | 2014-04-09 | 1 | -0/+3 |
| | |||||
* | Recognize NULL as an empty vector/string | Chris Robinson | 2014-04-03 | 1 | -5/+5 |
| | |||||
* | Don't pass the vector's capacity as a parameter to vector_reserve | Chris Robinson | 2014-03-31 | 1 | -3/+3 |
| | |||||
* | Add an al_string type and use it for the device lists | Chris Robinson | 2014-03-28 | 1 | -1/+6 |
| | |||||
* | Don't have VECTOR_INIT "return" anything | Chris Robinson | 2014-03-27 | 1 | -2/+2 |
| | |||||
* | Increase the vector reserve as needed when pushing in new items | Chris Robinson | 2014-03-21 | 1 | -4/+4 |
| | |||||
* | Rename the vector's Max field to Capacity | Chris Robinson | 2014-03-21 | 1 | -5/+5 |
| | |||||
* | Use vectors for the GenModList | Chris Robinson | 2014-03-21 | 1 | -1/+5 |
| | |||||
* | Add a generic vector interface and use it for the active effect slots | Chris Robinson | 2014-03-21 | 1 | -0/+38 |