Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | Rename alMain.h to alcmain.h | Chris Robinson | 2019-07-28 | 1 | -534/+0 |
| | | | | And move it and alu.h to Alc/. | ||||
* | Remove the UNUSED macro | Chris Robinson | 2019-07-28 | 1 | -13/+0 |
| | |||||
* | Clean up includes a bit | Chris Robinson | 2019-07-28 | 1 | -36/+22 |
| | | | | | | | Trying out the IWYU tool to only include what's necessary in a given file. Seems to work decently (it'll miss some headers, suggest unnecessary ones, and make nonsense suggestions for some things, but overall gives a good starting point), and helps clean out some headers. | ||||
* | Update a comment about the speaker distance | Chris Robinson | 2019-07-06 | 1 | -2/+2 |
| | |||||
* | Use a span for MixParams | Chris Robinson | 2019-07-04 | 1 | -3/+2 |
| | |||||
* | Use a span for RealMixParams | Chris Robinson | 2019-07-03 | 1 | -2/+1 |
| | |||||
* | Use explicit storage types for some enums | Chris Robinson | 2019-06-30 | 1 | -3/+3 |
| | |||||
* | Use a FlexArray for a device's contexts | Chris Robinson | 2019-06-29 | 1 | -1/+1 |
| | |||||
* | Use a FlexArray for the context's voices | Chris Robinson | 2019-06-09 | 1 | -1/+1 |
| | |||||
* | Use a bitfield for the device flags | Chris Robinson | 2019-06-08 | 1 | -15/+18 |
| | |||||
* | Fix for GCC 5.4 | Chris Robinson | 2019-06-08 | 1 | -3/+3 |
| | |||||
* | Simplify DistanceComp somewhat | Chris Robinson | 2019-06-08 | 1 | -14/+6 |
| | |||||
* | Remove the per-voice ChannelsPerOrder field | Chris Robinson | 2019-06-05 | 1 | -1/+1 |
| | |||||
* | Make some more channel counts unsigned | Chris Robinson | 2019-06-05 | 1 | -1/+1 |
| | |||||
* | Make RealMixParams channel count unsigned | Chris Robinson | 2019-06-05 | 1 | -1/+1 |
| | |||||
* | Don't log the function or prefix | Chris Robinson | 2019-06-04 | 1 | -1/+0 |
| | | | | | | It's ultimately unnecessary since the message is an indicator about where it was logged from. The message itself is generally more important than where it was from, too. | ||||
* | Use std::array for most mixing buffer arrays | Chris Robinson | 2019-05-28 | 1 | -3/+5 |
| | |||||
* | Get rid of the COUNTOF macro | Chris Robinson | 2019-05-26 | 1 | -6/+0 |
| | |||||
* | Change the default period size to 20ms | Chris Robinson | 2019-04-26 | 1 | -4/+4 |
| | |||||
* | Specify the buffer size as itself instead of the period count | Chris Robinson | 2019-04-26 | 1 | -1/+2 |
| | | | | | | | Certain backends don't need a buffer size to be a strict multiple of the period count, which allows a little more flexibility. The period/update size simply acts as the minimum request, which helps control CPU load by determining how often parameter and other pre-mixing updates are processed. | ||||
* | Change RealMixParams::ChannelName to better reflect its use | Chris Robinson | 2019-04-02 | 1 | -10/+4 |
| | |||||
* | Use a temporary buffer for HRTF filter accumulation | Chris Robinson | 2019-03-29 | 1 | -0/+1 |
| | | | | | Similar to the history buffer, to avoid using the state buffer as a ring buffer. | ||||
* | Avoid using the HRTF history buffer as a ring buffer | Chris Robinson | 2019-03-28 | 1 | -1/+5 |
| | | | | | | The HRTF mixers now get a full input buffer with the history prepended, so the delay offsets just need to account for the start point and read forward for each sample. | ||||
* | Move an enum to a more appropriate header | Chris Robinson | 2019-03-26 | 1 | -6/+0 |
| | |||||
* | Fix a comment typo | Chris Robinson | 2019-03-22 | 1 | -1/+1 |
| | |||||
* | Use a sorted vector for devices instead of a linked list | Chris Robinson | 2019-03-19 | 1 | -2/+0 |
| | |||||
* | Rename DevProbe enum names | Chris Robinson | 2019-03-19 | 1 | -3/+3 |
| | |||||
* | Move some inline functions from alMain.h to alnumeric.h | Chris Robinson | 2019-03-18 | 1 | -239/+0 |
| | |||||
* | Use SSE intrinsics in a few more places | Chris Robinson | 2019-03-18 | 1 | -6/+12 |
| | |||||
* | Use more specific names for temp buffer storage | Chris Robinson | 2019-03-02 | 1 | -1/+3 |
| | |||||
* | Reduce BUFFERSIZE to match the default period size | Chris Robinson | 2019-02-24 | 1 | -2/+9 |
| | | | | | Also adds a bit more space to the temp source data buffer, to avoid needing to loop on matching sample rates. | ||||
* | Remove the FOAOut mixing buffer and associated post-processes | Chris Robinson | 2019-02-22 | 1 | -8/+2 |
| | |||||
* | Avoid using internal AL[u]int64 types | Chris Robinson | 2019-02-11 | 1 | -9/+6 |
| | |||||
* | Get rid of the FAM_SIZE macro | Chris Robinson | 2019-02-11 | 1 | -6/+0 |
| | |||||
* | Move some number-related stuff to a separate header | Chris Robinson | 2019-02-11 | 1 | -31/+7 |
| | |||||
* | Constify some parameters | Chris Robinson | 2019-01-12 | 1 | -1/+1 |
| | |||||
* | Add prefixes for ALCdevice and ALCcontext | Chris Robinson | 2019-01-09 | 1 | -0/+1 |
| | |||||
* | Remove an unused macro | Chris Robinson | 2019-01-08 | 1 | -4/+0 |
| | |||||
* | Replace a couple more C-style casts | Chris Robinson | 2019-01-08 | 1 | -1/+1 |
| | |||||
* | Use user-defined literals for 64-bit literals | Chris Robinson | 2019-01-07 | 1 | -24/+7 |
| | |||||
* | Move some macros to a common header | Chris Robinson | 2019-01-07 | 1 | -35/+1 |
| | |||||
* | Simplify MixParams and AmbiUpsampler | Chris Robinson | 2019-01-05 | 1 | -20/+7 |
| | | | | Since the dry buffer is always an ambisonic target now | ||||
* | Rename ALCdevice_struct and ALCcontext_struct | Chris Robinson | 2019-01-01 | 1 | -5/+5 |
| | | | | | | | | | | | A (possibly contentious?) change in the public headers. Those names were never part of any specification, and I don't know why the struct names differed from the actual type name. But with C++, which takes the original struct declaration as the original name, it was affecting the type's internal symbols. This shouldn't affect user code since ALCdevice_struct and ALCcontext_struct were never part of the spec. If issues arise from this change, it should be reported. | ||||
* | Use an atomic bool on things that only take true or false | Chris Robinson | 2018-12-30 | 1 | -1/+1 |
| | |||||
* | Rename BackendLock to StateLock | Chris Robinson | 2018-12-30 | 1 | -1/+5 |
| | |||||
* | Return a unique_ptr for the backend | Chris Robinson | 2018-12-29 | 1 | -1/+1 |
| | |||||
* | Convert the backends to use proper inheritence | Chris Robinson | 2018-12-28 | 1 | -2/+2 |
| | |||||
* | Constify and reorder a couple device fields | Chris Robinson | 2018-12-27 | 1 | -4/+4 |
| | |||||
* | Cleanup some includes | Chris Robinson | 2018-12-25 | 1 | -13/+1 |
| | |||||
* | Remove extraneous typedef, struct, and enum keywords | Chris Robinson | 2018-12-24 | 1 | -17/+17 |
| |