aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Tisnovsky <[email protected]>2012-12-03 14:43:18 +0100
committerPavel Tisnovsky <[email protected]>2012-12-03 14:43:18 +0100
commit5c844362f517ee6704ff66d96c24c4f82b45374c (patch)
tree3b185d8d5e84698abd4bc8b539808458d15307d8 /Makefile.am
parent1afdb66f478fdd88e14ee60ace11e807d8aad09d (diff)
Added browser softkiller and related Makefile.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c6918cb..d66f278 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -39,6 +39,7 @@ export EXPORTED_TEST_CERT_SUFFIX=crt
export TEST_CERT_ALIAS=icedteaweb
export PUBLIC_KEYSTORE=${HOME}/.icedtea/security/trusted.certs
export PUBLIC_KEYSTORE_PASS=changeit
+export SOFTKILLER=softkiller
export JUNIT_RUNNER_JAR=$(abs_top_builddir)/junit-runner.jar
export UNIT_CLASS_NAMES = $(abs_top_builddir)/unit_class_names
@@ -808,9 +809,14 @@ $(REPRODUCERS_CLASS_NAMES): $(REPRODUCERS_CLASS_WHITELIST)
done ; \
echo $$class_names > $(REPRODUCERS_CLASS_NAMES)
+$(TESTS_DIR)/$(SOFTKILLER):
+ cd $(TESTS_SRCDIR)/$(SOFTKILLER); \
+ $(MAKE) ; \
+ mv $(SOFTKILLER) $(TESTS_DIR)/
+
stamps/run-netx-dist-tests.stamp: stamps/netx-dist.stamp extra-lib/about.jar stamps/plugin.stamp launcher.build/$(javaws) \
javaws.desktop stamps/docs.stamp launcher.build/$(itweb_settings) itweb-settings.desktop \
- stamps/netx.stamp stamps/junit-jnlp-dist-dirs stamps/netx-dist-tests-import-cert-to-public \
+ stamps/netx.stamp stamps/junit-jnlp-dist-dirs stamps/netx-dist-tests-import-cert-to-public $(TESTS_DIR)/softkiller \
stamps/test-extensions-compile.stamp stamps/compile-reproducers-testcases.stamp $(JUNIT_RUNNER_JAR) stamps/copy-reproducers-resources.stamp\
$(TESTS_DIR)/$(REPORT_STYLES_DIRNAME) $(REPRODUCERS_CLASS_NAMES) stamps/process-custom-reproducers.stamp
cd $(TEST_EXTENSIONS_DIR) ; \
@@ -1191,7 +1197,10 @@ clean_tests_reports:
rm -rf $(TESTS_DIR)/$(REPORT_STYLES_DIRNAME)/
rm -f $(TESTS_DIR)/*.html
-clean-netx-dist-tests: clean_tests_reports netx-dist-tests-remove-cert-from-public clean-custom-reproducers
+clean-$(SOFTKILLER):
+ rm $(TESTS_DIR)/softkiller
+
+clean-netx-dist-tests: clean_tests_reports netx-dist-tests-remove-cert-from-public clean-custom-reproducers clean-$(SOFTKILLER)
rm -f test-extensions-source-files.txt
rm -f test-extensions-tests-source-files.txt
rm -f $(TEST_EXTENSIONS_COMPATIBILITY_SYMLINK)