aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJiri Vanek <[email protected]>2011-05-17 16:43:45 +0200
committerJiri Vanek <[email protected]>2011-05-17 16:43:45 +0200
commitf28f5be45b529a049673e4d77787753162d1f152 (patch)
treeeedccf552aadc678e556955726e42ed4521c1595 /Makefile.am
parent3ad81af8c11d70e2cae4f7140e86d1cec1e02609 (diff)
added posibility to export junit testsuite results as xml
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e1553ac..a924e97 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -472,7 +472,10 @@ run-netx-unit-tests: stamps/netx-unit-tests-compile.stamp \
done ; \
echo $$class_names ; \
CLASSPATH=$(NETX_DIR)/lib/classes.jar:$(JUNIT_JAR):$(JUNIT_RUNNER_JAR):. \
- $(BOOT_DIR)/bin/java -Xbootclasspath:$(RUNTIME) CommandLine $$class_names
+ $(BOOT_DIR)/bin/java -Xbootclasspath:$(RUNTIME) CommandLine $$class_names \
+ > stdout.log 2> stderr.log ; \
+ cat stdout.log ; \
+ cat stderr.log >&2
clean-netx-tests: clean-netx-unit-tests clean-junit-runner
if [ -e $(TESTS_DIR)/netx ]; then \