aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorOmair Majid <[email protected]>2014-01-24 10:08:57 -0500
committerOmair Majid <[email protected]>2014-01-24 10:08:57 -0500
commitf877bfbde0a5a3375e1828c072f07bac5b3508a5 (patch)
treed9f39ac7bc6bd3084b3d0537c5798159553e376b /Makefile.am
parent5e29c4c6084a30b3102782ab7489ffb1a25c6c27 (diff)
Support building against OpenJDK9
OpenJDK9 does not have a PermGen and does not accept PermGen related flags. Remove them. 2014-01-23 Omair Majid <[email protected]> * Makefile.am [ENABLE_DOCS] [JAVADOC_SUPPORTS_J_OPTIONS]: Don't specify perm gen size.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 270ce8f..75cf2fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -172,7 +172,7 @@ if ENABLE_DOCS
JAVADOC_OPTS=-use -keywords -encoding UTF-8 -splitIndex \
-bottom '<font size="-1"> <a href="http://icedtea.classpath.org/bugzilla">Submit a bug or feature</a></font>'
if JAVADOC_SUPPORTS_J_OPTIONS
-JAVADOC_MEM_OPTS=-J-Xmx1024m -J-Xms128m -J-XX:PermSize=32m -J-XX:MaxPermSize=160m
+JAVADOC_MEM_OPTS=-J-Xmx1024m -J-Xms128m
endif
endif