aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorOmair Majid <[email protected]>2011-01-28 11:41:23 -0500
committerOmair Majid <[email protected]>2011-01-28 11:41:23 -0500
commitf64c8bd3c5ad5b3e12c2f767008944df7a79eea0 (patch)
treef3b78ad5684aae37ab7a34744e16396abe766c93 /configure.ac
parentd16944552990c2c953fdbd5e8d11f43e31dcbb3f (diff)
Use name and version as defined in configure.ac instead of hardcoding it in Boot.java
Use PACKAGE_NAME and FULL_VERSION as defined during build time rather than hardcoding them in net.sourceforge.jnlp.runtime.Boot. Generate a manifest file at build time, and define Implementation-Title and Implementation-Version to PACKAGE_NAME and FULL_VERSION. Use these values from the manifest file when displaying project name and version, rather than hardcoding "netx" and 0.5. 2011-01-28 Omair Majid <[email protected]> * Makefile.am: Move ICEDTEA_REV, ICEDTEA_PKG to acinclude.m4. Use FULL_VERSION. (stamps/netx-dist.stamp): Depend on netx.manifest. Use this file as the jar file manifest. * acinclude.m4 (IT_SET_VERSION): New macro. Defines FULL_VERSION. * configure.ac: Add netx.manifest to AC_CONFIG_FILES. Invoke IT_SET_VERSION. * netx.manifest.in: New file. * netx/net/sourceforge/jnlp/runtime/Boot.java: Set name and version using information from the manifest file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 189433b..38ddd6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
AC_INIT([icedtea-web],[1.1pre],[[email protected]], [icedtea-web], [http://icedtea.classpath.org/wiki/IcedTea-Web])
AM_INIT_AUTOMAKE([1.9 tar-pax foreign])
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([Makefile netx.manifest])
# Older automake doesn't generate these correctly
abs_top_builddir=`pwd -P`
@@ -35,8 +35,7 @@ FIND_ECJ_JAR
IT_FIND_JAVADOC
AC_CONFIG_FILES([javac], [chmod +x javac])
-IT_GET_PKGVERSION
-IT_OBTAIN_HG_REVISIONS
+IT_SET_VERSION
IT_CHECK_XULRUNNER_VERSION
AC_CHECK_LIB(z, main,, [AC_MSG_ERROR("zlib not found - try installing zlib-devel")])