aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-04-19 00:37:03 -0700
committerChris Robinson <[email protected]>2020-04-19 00:37:03 -0700
commit12d71a0ad1af132111f9e20d96df97d8da8b4853 (patch)
tree90e30aeaa5356aba78a27c9155cbaffc0cd04e31 /CMakeLists.txt
parent253773b3161a660f04ea4fa0dcf60e0ba7102f16 (diff)
Don't explicitly link libpthread
Compiling and linking with -pthread is apparently enough.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d02bcc17..12cbb742 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -450,11 +450,6 @@ IF(NOT WIN32)
SET(LINKER_FLAGS ${LINKER_FLAGS} -pthread)
ENDIF()
- CHECK_LIBRARY_EXISTS(pthread pthread_create "" HAVE_LIBPTHREAD)
- IF(HAVE_LIBPTHREAD)
- SET(EXTRA_LIBS pthread ${EXTRA_LIBS})
- ENDIF()
-
CHECK_SYMBOL_EXISTS(pthread_setschedparam pthread.h HAVE_PTHREAD_SETSCHEDPARAM)
# Some systems need pthread_np.h to get pthread_setname_np