aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-06-11 08:55:52 -0700
committerChris Robinson <[email protected]>2020-06-11 08:55:52 -0700
commit26eccd159f0256d92ffdb8bdc9dee0bf3e73be57 (patch)
tree8b2559fbb6d899076a7ec2adda76211b196b4d38 /CMakeLists.txt
parentad9fc31bfdda7f295083e44f78a5c98cca0c32d2 (diff)
Link with the CoreFoundation framework on iOS
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83eee139..73083973 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -961,8 +961,13 @@ if(COREAUDIO_FRAMEWORK AND AUDIOUNIT_INCLUDE_DIR)
set(HAVE_COREAUDIO 1)
set(ALC_OBJS ${ALC_OBJS} alc/backends/coreaudio.cpp alc/backends/coreaudio.h)
set(BACKENDS "${BACKENDS} CoreAudio,")
- set(EXTRA_LIBS ${COREAUDIO_FRAMEWORK} /System/Library/Frameworks/AudioUnit.framework
- /System/Library/Frameworks/ApplicationServices.framework ${EXTRA_LIBS})
+ if(CMAKE_SYSTEM_NAME STREQUAL "iOS")
+ find_library(COREFOUNDATION_FRAMEWORK NAMES CoreFoundation)
+ set(EXTRA_LIBS ${COREAUDIO_FRAMEWORK} ${COREFOUNDATION_FRAMEWORK} ${EXTRA_LIBS})
+ else()
+ set(EXTRA_LIBS ${COREAUDIO_FRAMEWORK} /System/Library/Frameworks/AudioUnit.framework
+ /System/Library/Frameworks/ApplicationServices.framework ${EXTRA_LIBS})
+ endif()
# Some versions of OSX may need the AudioToolbox framework. Add it if
# it's found.