aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2020-08-25 04:59:04 -0700
committerChris Robinson <[email protected]>2020-08-25 04:59:04 -0700
commit309be1c6f6bc6364d758712c29bb2ccbb1cc3511 (patch)
tree760172fbc0ed552b7b9b9bb238bac7c99df3e2be /CMakeLists.txt
parent801c7a92260dd524403f620d6003762899ca5df1 (diff)
Add an example using convolution reverb
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f77f5a24..092c041d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1508,6 +1508,10 @@ if(ALSOFT_EXAMPLES)
target_link_libraries(alstreamcb PRIVATE ${LINKER_FLAGS} SndFile::SndFile ex-common
${UNICODE_FLAG})
+ add_executable(alconvolve examples/alconvolve.cpp)
+ target_link_libraries(alconvolve PRIVATE ${LINKER_FLAGS} common SndFile::SndFile ex-common
+ ${UNICODE_FLAG})
+
if(ALSOFT_INSTALL_EXAMPLES)
set(EXTRA_INSTALLS ${EXTRA_INSTALLS} alplay alstream alreverb almultireverb allatency
alhrtf)