aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2022-11-23 06:41:49 -0800
committerChris Robinson <[email protected]>2022-11-23 06:41:49 -0800
commit3b838bc781ca2a314fa51e08389037ebce34a9cc (patch)
treea468a5266e920138e8367df460a29db37516cd79 /CMakeLists.txt
parent4b67a1f667297fed2d0dc4a910800b76e6c02e10 (diff)
Avoid overriding main with SDL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0a2e6d3..30820f91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1676,7 +1676,7 @@ if(ALSOFT_EXAMPLES)
if(SDL2_FOUND)
add_executable(alloopback examples/alloopback.c)
target_link_libraries(alloopback
- PRIVATE ${LINKER_FLAGS} SDL2::SDL2 SDL2::SDL2main ex-common ${MATH_LIB})
+ PRIVATE ${LINKER_FLAGS} SDL2::SDL2 ex-common ${MATH_LIB})
if(ALSOFT_INSTALL_EXAMPLES)
set(EXTRA_INSTALLS ${EXTRA_INSTALLS} alloopback)
@@ -1712,7 +1712,7 @@ if(ALSOFT_EXAMPLES)
add_executable(alffplay examples/alffplay.cpp)
target_include_directories(alffplay PRIVATE ${FFMPEG_INCLUDE_DIRS})
target_link_libraries(alffplay
- PRIVATE ${LINKER_FLAGS} SDL2::SDL2 SDL2::SDL2main ${FFMPEG_LIBRARIES} ex-common)
+ PRIVATE ${LINKER_FLAGS} SDL2::SDL2 ${FFMPEG_LIBRARIES} ex-common)
if(ALSOFT_INSTALL_EXAMPLES)
set(EXTRA_INSTALLS ${EXTRA_INSTALLS} alffplay)