aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2007-11-30 01:16:57 -0800
committerChris Robinson <[email protected]>2007-11-30 01:16:57 -0800
commit3bedb2b4e95e22353ccb0e976d5c320cd7572f10 (patch)
tree146d0c855191b13a37f28b6d3ed6ce82a4fb5de5 /CMakeLists.txt
parentab34e7c613aad78e193ba6f8a4d5631f1ba6a613 (diff)
Add _DEBUG/NDEBUG defines when DEBUG/NODEBUG options are used, respectively
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fd883d80..c6caaa77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,6 +83,12 @@ ELSE()
ENDIF()
ENDIF()
+IF(DEBUG)
+ ADD_DEFINITIONS(-D_DEBUG)
+ELSEIF(NODEBUG)
+ ADD_DEFINITIONS(-DNDEBUG)
+ENDIF()
+
CHECK_LIBRARY_EXISTS(m sqrtf "" HAVE_SQRTF)
CHECK_LIBRARY_EXISTS("" strtof "" HAVE_STRTOF)