aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2014-02-23 20:51:30 -0800
committerChris Robinson <[email protected]>2014-02-23 21:02:11 -0800
commit5731534e8d3582c2332a99e7355aa88534aa706b (patch)
tree0dd8fc8318960d8207cdaa603b89823105c500f2 /CMakeLists.txt
parent9f43de62ab62577a5159789eebcbb76768750418 (diff)
Move the default hrtf table to an external file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff746764..968ad9f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ OPTION(ALSOFT_NO_CONFIG_UTIL "Disable building the alsoft-config utility" OFF)
OPTION(ALSOFT_EXAMPLES "Build and install example programs" ON)
OPTION(ALSOFT_CONFIG "Install alsoft.conf sample configuration file" ON)
+OPTION(ALSOFT_HRTF_DEFS "Install HRTF definition files" ON)
IF(WIN32)
@@ -938,6 +939,15 @@ IF(ALSOFT_CONFIG)
MESSAGE(STATUS "")
ENDIF()
+# Install HRTF definitions
+IF(ALSOFT_HRTF_DEFS)
+ INSTALL(FILES hrtf/default-44100.mhr
+ DESTINATION share/openal/hrtf
+ )
+ MESSAGE(STATUS "Installing HRTF definitions")
+ MESSAGE(STATUS "")
+ENDIF()
+
IF(ALSOFT_UTILS)
ADD_EXECUTABLE(openal-info utils/openal-info.c)
TARGET_LINK_LIBRARIES(openal-info ${LIBNAME})