aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHALX99 <[email protected]>2021-05-13 18:53:26 +0800
committerGitHub <[email protected]>2021-05-13 18:53:26 +0800
commit66ebc3dc4ba690c810e973555846eceb659d8d55 (patch)
tree66c2591b8d823957dfc6f83194f04c38c92ca04f /CMakeLists.txt
parent1d7ff54f7de005faded1cc0568f3538c65bb4227 (diff)
Update CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 007c2cdf..8d6105e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@
cmake_minimum_required(VERSION 3.0.2)
-if(CMAKE_SYSTEM_NAME STREQUAL "iOS")
+if(APPLE)
# The workaround for try_compile failing with code signing
# since cmake-3.18.2, not required
set(CMAKE_TRY_COMPILE_PLATFORM_VARIABLES
@@ -11,7 +11,9 @@ if(CMAKE_SYSTEM_NAME STREQUAL "iOS")
"CMAKE_XCODE_ATTRIBUTE_CODE_SIGNING_ALLOWED")
set(CMAKE_XCODE_ATTRIBUTE_CODE_SIGNING_REQUIRED NO)
set(CMAKE_XCODE_ATTRIBUTE_CODE_SIGNING_ALLOWED NO)
+endif()
+if(CMAKE_SYSTEM_NAME STREQUAL "iOS")
# Fix compile failure with armv7 deployment target >= 11.0, xcode clang
# will report:
# error: invalid iOS deployment version '--target=armv7-apple-ios13.6',