aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2021-07-09 08:57:33 -0700
committerChris Robinson <[email protected]>2021-07-09 09:04:07 -0700
commit955fdebcad228e471c2f6f6c4ff976ca1bf442a0 (patch)
tree271527f25825271d35718bcf90a21a7f832c87ac /CMakeLists.txt
parent9a745292bd9263e0481dfb6c485e9fa961ca3cc4 (diff)
Add a utility to encode audio files to UHJ
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e754bf31..4b793518 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1496,6 +1496,14 @@ if(ALSOFT_UTILS)
target_compile_options(uhjdecoder PRIVATE ${C_FLAGS})
target_link_libraries(uhjdecoder PUBLIC common
PRIVATE ${LINKER_FLAGS} SndFile::SndFile ${UNICODE_FLAG})
+
+ add_executable(uhjencoder utils/uhjencoder.cpp)
+ target_compile_definitions(uhjencoder PRIVATE ${CPP_DEFS})
+ target_include_directories(uhjencoder
+ PRIVATE ${OpenAL_BINARY_DIR} ${OpenAL_SOURCE_DIR}/common)
+ target_compile_options(uhjencoder PRIVATE ${C_FLAGS})
+ target_link_libraries(uhjencoder PUBLIC common
+ PRIVATE ${LINKER_FLAGS} SndFile::SndFile ${UNICODE_FLAG})
endif()
if(MYSOFA_FOUND)