aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2013-10-27 07:03:58 -0700
committerChris Robinson <[email protected]>2013-10-27 07:03:58 -0700
commitb9e30f76041a029e9d4cd58f6c87086c0b527d6d (patch)
tree7baba3362ccdc2a29e3cc2f74752bb6399e9b304 /CMakeLists.txt
parentf93bfab82435b26fd03fe9dd0436f166758810d4 (diff)
Add a cmake option to disable building only alsoft-config
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9ed65804..f9efda81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,7 +70,8 @@ OPTION(ALSOFT_DLOPEN "Check for the dlopen API for loading optional libs" ON)
OPTION(ALSOFT_WERROR "Treat compile warnings as errors" OFF)
-OPTION(ALSOFT_UTILS "Build and install utility programs" ON)
+OPTION(ALSOFT_UTILS "Build and install utility programs" ON)
+OPTION(ALSOFT_NO_CONFIG_UTIL "Disable building the alsoft-config utility" OFF)
OPTION(ALSOFT_EXAMPLES "Build and install example programs" ON)
@@ -795,7 +796,7 @@ ENDIF()
# This is always available
SET(BACKENDS "${BACKENDS} Null")
-IF(ALSOFT_UTILS)
+IF(ALSOFT_UTILS AND NOT ALSOFT_NO_CONFIG_UTIL)
add_subdirectory(utils/alsoft-config)
ENDIF()
IF(ALSOFT_EXAMPLES)