aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-07-04 11:30:18 -0700
committerChris Robinson <[email protected]>2023-07-04 11:30:18 -0700
commitc12ada68951ea67a59bef7d4fcdf22334990c12a (patch)
tree1c38c022fd6ab499fc5a8616a3dfad0c6ae6c08f /CMakeLists.txt
parent3db472f9c6f5a9f012fb80d44b7bd310de99246a (diff)
Don't use an import target for OpenSL
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34fd3312..af25a96c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1183,7 +1183,8 @@ if(ALSOFT_BACKEND_OPENSL)
set(HAVE_OPENSL 1)
set(ALC_OBJS ${ALC_OBJS} alc/backends/opensl.cpp alc/backends/opensl.h)
set(BACKENDS "${BACKENDS} OpenSL,")
- set(EXTRA_LIBS "OpenSL::OpenSLES" ${EXTRA_LIBS})
+ set(EXTRA_LIBS ${OPENSL_LIBRARIES} ${EXTRA_LIBS})
+ set(INC_PATHS ${INC_PATHS} ${OPENSL_INCLUDE_DIRS})
endif()
endif()
if(ALSOFT_REQUIRE_OPENSL AND NOT HAVE_OPENSL)