aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-02-06 17:46:32 -0800
committerChris Robinson <[email protected]>2023-02-06 17:46:32 -0800
commitda845ddd9c35a1e1fcff03ea342636ae4bb8018b (patch)
tree8fe219826036410c655b7c732e94f04b442c3261 /CMakeLists.txt
parent0de7ea42fa197833bff70b4c370ed29f9859889d (diff)
Use an interpolated FIR filter for cubic resampling
Similar to how the bsinc filters work, but optimized for 4-point filtering. At least the SSE version is notably faster than calculating the coefficients in real time.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 379544fb..c37fe0b6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -654,6 +654,9 @@ set(CORE_OBJS
core/converter.h
core/cpu_caps.cpp
core/cpu_caps.h
+ core/cubic_defs.h
+ core/cubic_tables.cpp
+ core/cubic_tables.h
core/devformat.cpp
core/devformat.h
core/device.cpp