aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2012-10-07 08:08:11 -0700
committerChris Robinson <[email protected]>2012-10-07 08:08:11 -0700
commitebdf6367597d6cad0d6b53a3186c9331b20c94dd (patch)
tree7feb7d2ae2bb2ae2a5c5b362778f50266d7a25a5 /CMakeLists.txt
parent6b870714a91c9607acc4501234a00c7c94fa2b85 (diff)
Revert "Use __cpuid from intrin.h in Windows when available"
This reverts commit 6b870714a91c9607acc4501234a00c7c94fa2b85.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04d8f9c0..f8ba10e2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,8 +191,6 @@ IF(WIN32)
MESSAGE(STATUS "Could not find Wine header files" )
ENDIF()
ENDIF()
-
- CHECK_INCLUDE_FILE(intrin.h HAVE_INTRIN_H)
ELSE()
SET(OLD_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS}")
# Yes GCC, really don't accept visibility modes you don't support
@@ -280,9 +278,6 @@ IF(HAVE_FLOAT_H)
CHECK_SYMBOL_EXISTS(_controlfp float.h HAVE__CONTROLFP)
CHECK_SYMBOL_EXISTS(__control87_2 float.h HAVE___CONTROL87_2)
ENDIF()
-IF(HAVE_INTRIN_H)
- CHECK_SYMBOL_EXISTS(__cpuid intrin.h HAVE___CPUID)
-ENDIF()
CHECK_FUNCTION_EXISTS(strtof HAVE_STRTOF)
CHECK_FUNCTION_EXISTS(stat HAVE_STAT)