aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ff746764..968ad9f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ OPTION(ALSOFT_NO_CONFIG_UTIL "Disable building the alsoft-config utility" OFF)
OPTION(ALSOFT_EXAMPLES "Build and install example programs" ON)
OPTION(ALSOFT_CONFIG "Install alsoft.conf sample configuration file" ON)
+OPTION(ALSOFT_HRTF_DEFS "Install HRTF definition files" ON)
IF(WIN32)
@@ -938,6 +939,15 @@ IF(ALSOFT_CONFIG)
MESSAGE(STATUS "")
ENDIF()
+# Install HRTF definitions
+IF(ALSOFT_HRTF_DEFS)
+ INSTALL(FILES hrtf/default-44100.mhr
+ DESTINATION share/openal/hrtf
+ )
+ MESSAGE(STATUS "Installing HRTF definitions")
+ MESSAGE(STATUS "")
+ENDIF()
+
IF(ALSOFT_UTILS)
ADD_EXECUTABLE(openal-info utils/openal-info.c)
TARGET_LINK_LIBRARIES(openal-info ${LIBNAME})