aboutsummaryrefslogtreecommitdiffstats
path: root/utils/alsoft-config/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/alsoft-config/CMakeLists.txt')
-rw-r--r--utils/alsoft-config/CMakeLists.txt61
1 files changed, 45 insertions, 16 deletions
diff --git a/utils/alsoft-config/CMakeLists.txt b/utils/alsoft-config/CMakeLists.txt
index a6707a3d..67cc44c7 100644
--- a/utils/alsoft-config/CMakeLists.txt
+++ b/utils/alsoft-config/CMakeLists.txt
@@ -1,29 +1,58 @@
project(alsoft-config)
-include_directories("${alsoft-config_BINARY_DIR}")
+option(ALSOFT_NO_QT5 "Use Qt4 instead of Qt5 for alsoft-config" FALSE)
-# Need Qt 4.8.0 or newer for the iconset theme attribute to work
-find_package(Qt4 4.8.0 COMPONENTS QtCore QtGui)
-if(QT4_FOUND)
- include(${QT_USE_FILE})
+include_directories("${alsoft-config_BINARY_DIR}")
- set(alsoft-config_SRCS main.cpp
- mainwindow.cpp
- )
+set(alsoft-config_SRCS
+ main.cpp
+ mainwindow.cpp
+ mainwindow.h
+)
+set(alsoft-config_UIS mainwindow.ui)
+set(alsoft-config_MOCS mainwindow.h)
- set(alsoft-config_UIS mainwindow.ui)
- QT4_WRAP_UI(UIS ${alsoft-config_UIS})
+find_package(Qt5Widgets)
+if(Qt5Widgets_FOUND AND NOT ALSOFT_NO_QT5)
+ qt5_wrap_ui(UIS ${alsoft-config_UIS})
- set(alsoft-config_MOCS mainwindow.h)
- QT4_WRAP_CPP(MOCS ${alsoft-config_MOCS})
+ qt5_wrap_cpp(MOCS ${alsoft-config_MOCS})
add_executable(alsoft-config ${alsoft-config_SRCS} ${UIS} ${RSCS} ${TRS} ${MOCS})
- target_link_libraries(alsoft-config ${QT_LIBRARIES})
+ target_link_libraries(alsoft-config Qt5::Widgets)
+ set_property(TARGET alsoft-config APPEND PROPERTY COMPILE_FLAGS ${EXTRA_CFLAGS})
set_target_properties(alsoft-config PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${OpenAL_BINARY_DIR})
+ if(TARGET build_version)
+ add_dependencies(alsoft-config build_version)
+ endif()
install(TARGETS alsoft-config
- RUNTIME DESTINATION bin
- LIBRARY DESTINATION "lib${LIB_SUFFIX}"
- ARCHIVE DESTINATION "lib${LIB_SUFFIX}"
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
+else()
+ # Need Qt 4.8.0 or newer for the iconset theme attribute to work
+ find_package(Qt4 4.8.0 COMPONENTS QtCore QtGui)
+ if(QT4_FOUND)
+ include(${QT_USE_FILE})
+
+ qt4_wrap_ui(UIS ${alsoft-config_UIS})
+
+ qt4_wrap_cpp(MOCS ${alsoft-config_MOCS})
+
+ add_executable(alsoft-config ${alsoft-config_SRCS} ${UIS} ${RSCS} ${TRS} ${MOCS})
+ target_link_libraries(alsoft-config ${QT_LIBRARIES})
+ set_property(TARGET alsoft-config APPEND PROPERTY COMPILE_FLAGS ${EXTRA_CFLAGS})
+ set_target_properties(alsoft-config PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${OpenAL_BINARY_DIR})
+ if(TARGET build_version)
+ add_dependencies(alsoft-config build_version)
+ endif()
+
+ install(TARGETS alsoft-config
+ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
+ )
+ endif()
endif()