aboutsummaryrefslogtreecommitdiffstats
path: root/OpenAL32/Include/alMain.h
Commit message (Expand)AuthorAgeFilesLines
* Rename alMain.h to alcmain.hChris Robinson2019-07-281-534/+0
* Remove the UNUSED macroChris Robinson2019-07-281-13/+0
* Clean up includes a bitChris Robinson2019-07-281-36/+22
* Update a comment about the speaker distanceChris Robinson2019-07-061-2/+2
* Use a span for MixParamsChris Robinson2019-07-041-3/+2
* Use a span for RealMixParamsChris Robinson2019-07-031-2/+1
* Use explicit storage types for some enumsChris Robinson2019-06-301-3/+3
* Use a FlexArray for a device's contextsChris Robinson2019-06-291-1/+1
* Use a FlexArray for the context's voicesChris Robinson2019-06-091-1/+1
* Use a bitfield for the device flagsChris Robinson2019-06-081-15/+18
* Fix for GCC 5.4Chris Robinson2019-06-081-3/+3
* Simplify DistanceComp somewhatChris Robinson2019-06-081-14/+6
* Remove the per-voice ChannelsPerOrder fieldChris Robinson2019-06-051-1/+1
* Make some more channel counts unsignedChris Robinson2019-06-051-1/+1
* Make RealMixParams channel count unsignedChris Robinson2019-06-051-1/+1
* Don't log the function or prefixChris Robinson2019-06-041-1/+0
* Use std::array for most mixing buffer arraysChris Robinson2019-05-281-3/+5
* Get rid of the COUNTOF macroChris Robinson2019-05-261-6/+0
* Change the default period size to 20msChris Robinson2019-04-261-4/+4
* Specify the buffer size as itself instead of the period countChris Robinson2019-04-261-1/+2
* Change RealMixParams::ChannelName to better reflect its useChris Robinson2019-04-021-10/+4
* Use a temporary buffer for HRTF filter accumulationChris Robinson2019-03-291-0/+1
* Avoid using the HRTF history buffer as a ring bufferChris Robinson2019-03-281-1/+5
* Move an enum to a more appropriate headerChris Robinson2019-03-261-6/+0
* Fix a comment typoChris Robinson2019-03-221-1/+1
* Use a sorted vector for devices instead of a linked listChris Robinson2019-03-191-2/+0
* Rename DevProbe enum namesChris Robinson2019-03-191-3/+3
* Move some inline functions from alMain.h to alnumeric.hChris Robinson2019-03-181-239/+0
* Use SSE intrinsics in a few more placesChris Robinson2019-03-181-6/+12
* Use more specific names for temp buffer storageChris Robinson2019-03-021-1/+3
* Reduce BUFFERSIZE to match the default period sizeChris Robinson2019-02-241-2/+9
* Remove the FOAOut mixing buffer and associated post-processesChris Robinson2019-02-221-8/+2
* Avoid using internal AL[u]int64 typesChris Robinson2019-02-111-9/+6
* Get rid of the FAM_SIZE macroChris Robinson2019-02-111-6/+0
* Move some number-related stuff to a separate headerChris Robinson2019-02-111-31/+7
* Constify some parametersChris Robinson2019-01-121-1/+1
* Add prefixes for ALCdevice and ALCcontextChris Robinson2019-01-091-0/+1
* Remove an unused macroChris Robinson2019-01-081-4/+0
* Replace a couple more C-style castsChris Robinson2019-01-081-1/+1
* Use user-defined literals for 64-bit literalsChris Robinson2019-01-071-24/+7
* Move some macros to a common headerChris Robinson2019-01-071-35/+1
* Simplify MixParams and AmbiUpsamplerChris Robinson2019-01-051-20/+7
* Rename ALCdevice_struct and ALCcontext_structChris Robinson2019-01-011-5/+5
* Use an atomic bool on things that only take true or falseChris Robinson2018-12-301-1/+1
* Rename BackendLock to StateLockChris Robinson2018-12-301-1/+5
* Return a unique_ptr for the backendChris Robinson2018-12-291-1/+1
* Convert the backends to use proper inheritenceChris Robinson2018-12-281-2/+2
* Constify and reorder a couple device fieldsChris Robinson2018-12-271-4/+4
* Cleanup some includesChris Robinson2018-12-251-13/+1
* Remove extraneous typedef, struct, and enum keywordsChris Robinson2018-12-241-17/+17